Visualization with ParaView
Before we begin…

• Make sure you have ParaView 3.14 installed so you can follow along in the lab section

• All data for this tutorial can be found here:
  – [http://portal.longhorn.tacc.utexas.edu/training](http://portal.longhorn.tacc.utexas.edu/training)
Background

• Open-source, multi-platform parallel data analysis and visualization application
• Mature, feature-rich interface
• Good for general-purpose, rapid visualization
• Built upon the Visualization ToolKit (VTK) library
• Primary contributors:
  – Kitware, Inc.
  – Sandia National Laboratory
  – Los Alamos National Laboratory
  – Army Research Laboratory
Data Types

• Supports a wide variety of data types
  – Structured grids
    • uniform rectilinear, non-uniform rectilinear, and curvilinear
  – Unstructured grids
  – Polygonal data
  – Images
  – Multi-block
  – AMR

• Time series support
Visualization Algorithms

- Supports a wide variety of visualization algorithms
  - Isosurfaces
  - Cutting planes
  - Streamlines
  - Glyphs
  - Volume rendering
  - Clipping
  - Height maps
  - ...
Special Features

• Supports derived variables
  – New scalar / vector variables that are functions of existing variables in your data set

• Scriptable via Python

• Saves animations

• Can run in parallel / distributed mode for large data visualization
Data Formats

• Supports a wide variety of data formats
  – VTK (http://www.vtk.org/VTK/img/file-formats.pdf)
  – EnSight
  – Plot3D
  – Various polygonal formats
  – “Block of floats”

• Users can write data readers to extend support to other formats

• Conversion to the VTK format is straightforward
Data Formats

- VTK Simple Legacy Format
  - ASCII or binary
  - Supports all VTK grid types
  - Easiest for data conversion

- **Note**: use VTK XML format for parallel I/O

VTK simple legacy format ([http://www.vtk.org/VTK/img/file-formats.pdf](http://www.vtk.org/VTK/img/file-formats.pdf))
Data Formatting Example

• Data set: 4x4x4 rectilinear grid with one scalar variable

```
# vtk DataFile Version 2.0
one scalar variable on a rectilinear grid
ASCII
DATASET RECTILINEAR_GRID
DIMENSIONS 4 4 4
X_COORDINATES 4 float
  0  1 2.5  4.5
Y_COORDINATES 4 float
  0  2  4  6
Z_COORDINATES 4 float
  0  3  6  9
POINT_DATA 64
SCALARS scalar_variable float 1
LOOKUP_TABLE default
  0  1  2  3  4  5  6  7  8  9 10 11 12 13 14 15 16
  17 18 19 20 21 22 23 24 25 26 27 28 29 30
  31 32 33 34 35 36 37 38 39 40 41 42 43 44
  45 46 47 48 49 50 51 52 53 54 55 56 57 58
  59 60 61 62 63
```
ParaView Visualization Pipeline

- All processing operations (filters) produce data sets
- Can further process the result of every operation to build complex visualizations
  - e.g. can extract a cutting plane, and apply glyphs (i.e. vector arrows) to the result
    - Gives a plane of glyphs through your 3D volume
Demonstration

• WRF weather forecast data set
  – Rectilinear grid
  – Multiple scalar and vector variables
  – Time series

• Can show:
  – Clouds
  – Wind
  – Temperature
  – …
ParaView Test-Drive
Getting Started

• Download example data file ‘RectGrid2.vtk’
  – http://portal.longhorn.tacc.utexas.edu/training/RectGrid2.vtk
  – Right-click, Save link as…

• Open ParaView
ParaView

Today we will:

• Create isosurfaces for a scalar variable
• Clip and slice the isosurfaces
• Use glyphs to display a vector field
• Use streamlines to show flow through a vector field
• Edit color maps
• Add slices to show variable values over a plane
• Adjust opacities of filters
• Add color legends
• Create volume rendering
ParaView

Open the file
RectGrid2.vtk

- **Click** File -> Open
- **Select** RectGrid2.vtk
- **Click** OK
- **Click blue** Apply
- Box outline of dataset extent displayed
Open the file RectGrid2.vtk

- Click File -> Open
- Select RectGrid2.vtk
- Click OK
- Click blue Apply
- Box outline of dataset extent displayed
ParaView

Open the file
RectGrid2.vtk
- Click File -> Open
- Select RectGrid2.vtk
- Click OK
- Click blue Apply
- Box outline of dataset extent displayed
ParaView

Open the file RectGrid2.vtk

- Click File -> Open
- Select RectGrid2.vtk
- Click OK
- Click blue Apply
- Box outline of dataset extent displayed
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- In Isosurfaces box, click Delete All
- **Click** New Range
- Keep defaults, click OK
- **Click** blue Apply
- **Click** Display tab
- In **Color by** box, select vectors
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- **In Isosurfaces box, click** Delete All
- **Click** New Range
- Keep defaults, **click** OK
- **Click** blue Apply
- **Click** Display tab
- **In Color by box, select** vectors
ParaView

Create isosurfaces
- Click Filters -> Common -> Contour
- In Isosurfaces box, click Delete All
- Click New Range
- Keep defaults, click OK
- Click blue Apply
- Click Display tab
- In Color by box, select vectors
Create isosurfaces

- Click **Filters** -> Common -> **Contour**
- In **Isosurfaces** box, click **Delete All**
- Click **New Range**
- Keep defaults, click **OK**
- **Click blue** **Apply**
- Click **Display** tab
- In **Color by** box, select **vectors**
ParaView

Create isosurfaces

- Click Filters -> Common -> Contour
- In Isosurfaces box, click Delete All
- Click New Range
- Keep defaults, click OK
- Click blue Apply
- Click Display tab
- In Color by box, select vectors
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- **In Isosurfaces box**, click Delete All
- **Click** New Range
- **Keep defaults**, click **OK**
- **Click** blue **Apply**
- **Click** Display tab
- **In Color by box**, select **vectors**
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- **In Isosurfaces box, click** Delete All
- **Click** New Range
- **Keep defaults, click** OK
- **Click blue Apply**
- **Click** Display tab
- **In Color by box, select vectors**
ParaView

Clip isosurfaces

- **Click** +Y view button
- **Click** Filters -> Common -> Clip
- **Show Plane** should be checked
- Drag arrow point around to front of surface (arrow turns red when selected)
- **Click** Inside Out checkbox
- **Click** blue **Apply**
- **Click** Show Center button to remove crosshairs
Clip isosurfaces

- Click $+Y$ view button
- Click Filters -> Common -> Clip
- Show Plane should be checked
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click Inside Out checkbox
- Click blue Apply
- Click Show Center button to remove crosshairs
ParaView

Clip isosurfaces

- Click +Y view button
- Click Filters -> Common -> Clip
- Show Plane should be checked
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click Inside Out checkbox
- Click blue Apply
- Click Show Center button to remove crosshairs
ParaView

Clip isosurfaces
• Click +Y view button
• Click Filters -> Common -> Clip
• Show Plane should be checked
• Drag arrow point around to front of surface (arrow turns red when selected)
• Click Inside Out checkbox
• Click blue Apply
• Click Show Center button to remove crosshairs
ParaView

Slice isosurfaces

- Click eye next to **Clip1** to hide clip plot
- Click **Contour1** in Pipeline Browser
- Click **Filters -> Common -> Slice**
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click blue **Apply**
ParaView

Slice isosurfaces

- Click eye next to Clip1 to hide clip plot
- Click Contour1 in Pipeline Browser
- Click Filters -> Common -> Slice
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click blue Apply
ParaView

Slice isosurfaces

- Click eye next to Clip1 to hide clip plot
- Click Contour1 in Pipeline Browser
- Click Filters -> Common -> Slice
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click blue Apply
ParaView

Slice isosurfaces

• Click eye next to Clip1 to hide clip plot
• Click Contour1 in Pipeline Browser
• Click Filters -> Common -> Slice
• Drag arrow point around to front of surface (arrow turns red when selected)
• Click blue Apply
ParaView

Slice isosurfaces

- Click eye next to Clip1 to hide clip plot
- Click Contour1 in Pipeline Browser
- Click Filters -> Common -> Slice
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click blue Apply
ParaView

Slice isosurfaces

- Click eye next to Clip1 to hide clip plot
- Click Contour1 in Pipeline Browser
- Click Filters -> Common -> Slice
- Drag arrow point around to front of surface (arrow turns red when selected)
- Click blue Apply
ParaView

Create Glyph of Vector Field

- **Click** `RectGrid2.vtk` in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Click** blue Apply
ParaView

Create Glyph of Vector Field

- **Click** `RectGrid2.vtk` in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Click blue** Apply
ParaView

Create Glyph of Vector Field

- **Click** `RectGrid2.vtk` in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Click blue** Apply
ParaView

Create Glyph of Vector Field

- Click `RectGrid2.vtk` in Pipeline Browser
- Click Filters -> Common -> Glyph
- Click blue `Apply`
ParaView

Create Streamlines

- Click eye next to Glyph1 to hide glyph plot
- Click RectGrid2.vtk in Pipeline Browser
- Click Filters -> Common -> Stream Tracer
- Click blue Apply
- Under Display tab, in the Color by box, select Vorticity
ParaView

Create Streamlines

• Click eye next to Glyph1 to hide glyph plot

• **Click RectGrid2.vtk in Pipeline Browser**

• Click Filters -> Common -> Stream Tracer

• Click blue Apply

• Under Display tab, in the Color by box, select Vorticity
ParaView

Create Streamlines

- Click eye next to **Glyph1** to hide glyph plot
- Click **RectGrid2.vtk** in Pipeline Browser
- **Click Filters -> Common -> Stream Tracer**
- Click blue **Apply**
- **Under Display tab, in the Color by box, select Vorticity**
ParaView

Create Streamlines

- Click eye next to Glyph1 to hide glyph plot
- Click RectGrid2.vtk in Pipeline Browser
- Click Filters -> Common -> Stream Tracer
- Click blue Apply
- Under Display tab, in the Color by box, select Vorticity
ParaView

Create Streamlines

- Click eye next to Glyph1 to hide glyph plot
- Click RectGrid2.vtk in Pipeline Browser
- Click Filters -> Common -> Stream Tracer
- Click blue Apply
- Under Display tab, in the Color by box, select Vorticity
ParaView

Create Streamlines

- Click eye next to Glyph1 to hide glyph plot
- Click RectGrid2.vtk in Pipeline Browser
- Click Filters -> Common -> Stream Tracer
- Click blue Apply
- Under Display tab, in the Color by box, select Vorticity
ParaView

Create Streamlines

• Click eye next to Glyph1 to hide glyph plot
• Click RectGrid2.vtk in Pipeline Browser
• Click Filters -> Common -> Stream Tracer
• Click blue Apply
• Under Display tab, in the Color by box, select Vorticity
ParaView

Create Tubes

• **Click** StreamTracer1 in Pipeline Browser
• **Click** Filters -> Alphabetical -> Tube
• **Click** blue Apply
ParaView

Create Tubes

- Click StreamTracer1 in Pipeline Browser
- **Click Filters -> Alphabetical -> Tube**
- Click blue **Apply**
ParaView

Create Tubes

- Click StreamTracer1 in Pipeline Browser
- Click Filters -> Alphabetical -> Tube
- Click blue Apply
ParaView

Create Tubes

- Click **StreamTracer1** in Pipeline Browser
- Click **Filters -> Alphabetical -> Tube**
- Click blue **Apply**
ParaView

Edit Color Map

- **Click Edit Color Map**
- **Click Choose Preset**
- **Select BLUE...HSV**
- **Click blue OK**
- **Click blue Close**
Edit Color Map

- **Click** Edit Color Map
- **Click** Choose Preset
- **Select** BLUE...HSV
- **Click** blue OK
- **Click** blue Close
ParaView

Edit Color Map

- Click Edit Color Map
- **Click** Choose Preset
- **Select** BLUE...HSV
- Click blue OK
- Click blue Close
ParaView

Edit Color Map

- Click Edit Color Map
- **Click** Choose Preset
- **Select** BLUE...HSV
- Click blue OK
- Click blue Close
ParaView

Edit Color Map

- Click Edit Color Map
- Click Choose Preset
- Select BLUE...HSV
- Click blue OK
- Click blue Close
ParaView

Edit Color Map

- Click Edit Color Map
- Click Choose Preset
- Select BLUE...HSV
- Click blue OK
- Click blue Close
ParaView

Edit Color Map

• Click Edit Color Map
• Click Choose Preset
• Select BLUE...HSV
• Click blue OK
• Click blue Close
ParaView

Create Slice

- Click **RectGrid2.vtk** in Pipeline Browser
- Click **Filters -> Common -> Slice**
- Drag arrow point around to front of surface (arrow turns red when selected)
- Or click **Y Normal**
- Click blue **Apply**
- Click **Show Plane**
ParaView

Create Slice

• Click RectGrid2.vtk in Pipeline Browser
• Click Filters -> Common -> Slice
• Drag arrow point around to front of surface (arrow turns red when selected)
• Or click Y Normal
• Click blue Apply
• Click Show Plane
ParaView

Create Slice

- Click **RectGrid2.vtk** in Pipeline Browser
- Click **Filters -> Common -> Slice**
- Drag arrow point around to front of surface (arrow turns red when selected)
- Or click **Y Normal**
- **Click blue Apply**
- Click **Show Plane**
ParaView

Create Slice

• Click RectGrid2.vtk in Pipeline Browser
• Click Filters -> Common -> Slice
• Drag arrow point around to front of surface (arrow turns red when selected)
• Or click Y Normal
• Click blue Apply
• Click Show Plane
ParaView

Create Slice

- Click **RectGrid2.vtk** in Pipeline Browser
- Click **Filters -> Common -> Slice**
- Drag arrow point around to front of surface (arrow turns red when selected)
- Or click **Y Normal**
- Click blue **Apply**
- Click **Show Plane**
ParaView

Background Color

- **Click the button above the 3D view**
- **Click Choose Color**
- **Drag box to black**
- **Click blue Ok**
- **Click blue Ok**
ParaView

Background Color

- Click the button above the 3D view
- **Click Choose Color**
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Background Color

- Click the button above the 3D view
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Background Color

- Click the button above the 3D view
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Background Color

- Click the button above the 3D view
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Object Opacity

- Click **Slice2** in Pipeline Browser
- Click **Display**
- Change **Opacity to 0.70** → Enter
- Click **Color by vectors**
- Click eye next to **RectGrid2.vtk** to hide box outline
ParaView

Object Opacity

- Click **Slice2** in Pipeline Browser
- Click **Display**
- **Change** Opacity to 0.70 -> Enter
- Click **Color by vectors**
- Click eye next to **RectGrid2.vtk** to hide box outline
ParaView

Object Opacity

- **Click** `Slice2` in Pipeline Browser
- **Click** Display
- **Change** Opacity to 0.70 -> Enter
- **Click Color by** vectors
- **Click** eye next to `RectGrid2.vtk` to hide box outline
ParaView

Object Opacity

- Click **Slice2** in Pipeline Browser
- Click **Display**
- Change **Opacity to 0.70** -> Enter
- Click **Color by vectors**
- Click eye next to **RectGrid2.vtk** to hide box outline
ParaView

Object Opacity

- **Click** Slice2 in Pipeline Browser
- **Click** Display
- **Change** Opacity to 0.70 → Enter
- **Click** Color by vectors
- **Click** eye next to RectGrid2.vtk to hide box outline
ParaView

Enable Color Legend

- **Click** Display
- **Click** Edit Color Map
- **Click** Color Legend
- **Click** Show Color Legend
- **Click** -> Blue Close
- **Select** Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable Color Legend

- Click Display
- Click Edit Color Map
- Click Color Legend
- **Click** Show Color Legend
- Click -> Blue Close
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable Color Legend

- **Click** Display
- **Click** Edit Color Map
- **Click** Color Legend
- **Click** Show Color Legend
- **Click** -> **Blue Close**
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable Color Legend

- Click Display
- Click Edit Color Map
- Click Color Legend
- Click Show Color Legend
- Click -> Blue Close
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable Color Legend

- **Click** Display
- **Click** Edit Color Map
- **Click** Color Legend
- **Click** Show Color Legend
- **Click** -> Blue Close
- **Select** Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Create Volume Rendering

- **Click** `RectGrid2.vtk` in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tetrahedralize
- **Click** -> Apply
- **Click** Display
- **Click** Representation
- **Select** Volume
- **Click** -> Edit Color Map (To edit transfer function)
ParaView

Create Volume Rendering

- Click **RectGrid2.vtk** in Pipeline Browser
- Click **Filters -> Alphabetical -> Tetrahedralize**
- Click **-> Apply**
- Click **Display**
- Click **Representation**
- Select **Volume**
- Click **-> Edit Color Map** (To edit transfer function)
ParaView

Create Volume Rendering

1. **Click** RectGrid2.vtk in Pipeline Browser
2. **Click** Filters -> Alphabetical -> Tetrahedralize
3. **Click** -> Apply
4. **Click** Display
5. **Click** Representation
6. **Select** Volume
7. **Click** -> Edit Color Map (To edit transfer function)
ParaView

Create Volume Rendering
- **Click** RectGrid2.vtk in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tetrahedralize
- **Click** -> Apply
- **Click** Display
- **Click** Representation
- **Select** Volume
- **Click** -> Edit Color Map (To edit transfer function)
ParaView

Create Volume Rendering

- **Click** `RectGrid2.vtk` in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tetrahedralize
- **Click** Apply
- **Click** Display
- **Click** Representation
- **Select** Volume
- **Click** -> Edit Color Map (to edit transfer function)
ParaView

Create Volume Rendering

- **Click** RectGrid2.vtk in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tetrahedralize
- **Click** -> Apply
- **Click** Display
- **Click** Representation
- **Select** Volume
- **Click** -> Edit Color Map (to edit transfer function)
Questions?

• More tutorials available: