VisIt Tutorial
Background

• [https://wci.llnl.gov/codes/visit/](https://wci.llnl.gov/codes/visit/)
• Open Source, Multiplatform, interactive parallel visualization and graphical analysis tool
• Developed by the Department of Energy (DOE) Advanced Simulation and Computing Initiative (ASCI)
• Although VisIt was developed for visualizing terascale data, it is also well suited typical desktop simulations
Data Types

• Supports a wide variety of data types
  – Structured grids
    • uniform rectilinear, non-uniform rectilinear, and curvilinear
  – Unstructured grids
  – Polygonal data
  – Images
  – Multi-block
  – AMR

• Time series support
Visualization Algorithms

- VisIt’s visualization capabilities are grouped into two categories:
  - Plots are used to visualize data and include boundary, contour, label, mesh, pseudocolor, scatter, streamline, and others.
  - Operators consist of operations that can be performed on the data prior to visualization. (Examples include slice, isosurface, threshold among others)
Special Features

• Supports derived fields
  – New fields to be calculated using existing fields.

• Supports multiple mesh types (rectilinear, curvilinear, and unstructured meshes)

• Employs distributed architecture to handle extremely large data sets interactively
Data Formats

• Supports over 100 different file formats
  http://visitusers.org/index.php?title=Detailed_list_of_file_formats_VisIt_supports

  – Application Formats
    • FLASH, Fluent, Gadget, LAMMPS, etc.

  – General Scientific Formats
    • HDF5, NetCDF, Silo, etc.

  – Visualization Formats
    • EnSight, TecPlot, VTK, etc.
VisIt Test-Drive
Getting Started

• Download example data file ‘noise.silo’
  – Right-click, Save link as…

• Open VisIt
Today we will:

- Create contours for a scalar variable
- Create isosurfaces for a scalar variable
- Clip and slice the isosurfaces
- Use glyphs to display a vector field
- Use streamlines to show flow through a vector field
- Edit annotations and background
- Add slices to show variable values over a plane
- Create volume rendering
Open the file (and display information)

Noise.silo

- **Click** File -> Open file
- **Select** noise.silo
- **Click** OK
- **Note** name of file under -> Active source
- **Click** File -> File information
- **Close** Window
Open the file (and display information)

Noise.silo

- **Click** File -> Open file
- **Select** noise.silo
- **Click** OK
- **Note** name of file under -> Active source
- **Click** File -> File information
- **Close** Window
VisIt

Open the file (and display information)

Noise.silo

• Click File -> Open file
• Select noise.silo
• Click OK
• Note name of file under -> Active source
• Click File -> File information
• Close Window
Open the file (and display information)

Noise.silo

- Click File -> Open file
- Select noise.silo
- Click OK
- Note name of file under -> Active source
- Click File -> File information
- Close Window
Open the file (and display information)

Noise.silo

- **Click** File -> Open file
- **Select** noise.silo
- **Click** OK
- **Note** name of file under -> Active source
- **Click** File -> File information
- **Close** Window
Create contour

- **Click** Add -> Contour -> hardyglobal
- **Click** Draw
- Double click on Contour
- Under select by choose ->\(\text{N}\) Levels **enter** 5
- Change the opacity levels
- **Click** Apply
- **Click** Dismiss
- **Click** Delete
Create contour

- Click Add -> Contour -> hardyglobals
- Click Draw
- Double click on Contour
- Under select by choose -> N Levels enter 5
- Change the opacity levels
- Click Apply
- Click Dismiss
- Click Delete
Create contour

- **Click** Add -> Contour -> hardyglobal
- **Click** Draw
- Double click on Contour
- Under select by choose -> N Levels enter 5
- Change the opacity levels
- Click Apply
- Click Dismiss
- Click Delete
Create contour

- **Click** Add -> Contour -> hardyglobal
- **Click** Draw
- **Double click on** Contour
- Under select by choose -> N Levels **enter** 5
- Change the opacity levels
- **Click** Apply
- **Click** Dismiss
- **Click** Delete
Create contour

- Click Add -> Contour -> hardyglobal
- Click Draw
- Double click on Contour
- Under select by choose -> N Levels enter 5
- Change the opacity levels
- Click Apply
- Click Dismiss
- Click Delete
VisIt

Create contour

- Click Add -> Contour -> hardyglobal
- Click Draw
- Double click on Contour (or Right-click -> Edit plot description)
- Under select by choose -> N Levels enter 5
- Change the opacity levels
- Click Apply
- Click Dismiss
- Click Delete
Create contour
- **Click** Add -> Contour -> hardyglobal
- **Click** Draw
- **Double click on** Contour (or Right-click -> Edit plot description)
- **Under select by choose** -> N Levels enter 5
- **Change the opacity levels**
- **Click** Apply
- **Click** Dismiss
- **Click** Delete
Create contour

- **Click** Add -> Contour -> hardyglobal
- **Click** Draw
- **Double click on** Contour (or Right-click -> Edit plot description)
- **Under select by choose** -> N Levels enter 5
- **Change the opacity levels**
- **Click**Dismiss
- **Click** Delete
Create Pseudocolor and isosurfaces

- **Click** Add -> Pseudocolor -> hardyglobal
- **Click** Draw
- **Click** Operator -> Slicing -> Isosurface
- **Click** Draw
- **Click** Arrow to expand
- **Double-Click** Isosurface
- **Under select by choose -> Percent(s)** enter 50
- **Click** Apply & Dismiss
Create Pseudocolor and isosurfaces

- **Click** Add -> Pseudocolor -> hardyglobal
- **Click** **Draw**
- **Click** Operator -> Slicing -> Isosurface
- **Click** **Draw**
- **Click** Arrow to expand
- **Double-Click** Isosurface
- **Under select by choose ->** Percent(s) **enter** 50
- **Click** **Apply & Dismiss**
VisIt

Create Pseudocolor and isosurfaces

• **Click Add** -> Pseudocolor -> hardyglobal
• **Click Draw**
• **Click Operator** -> Slicing -> Isosurface
• **Click Draw**
• **Click Arrow to expand**
• **Double-Click Isosurface**
• **Under select by choose** -> Percent(s) enter 50
• **Click Apply & Dismiss**
VisIt

Create Pseudocolor and isosurfaces

- **Click** Add ->
  Pseudocolor ->
  hardyglobal
- **Click** Draw
- **Click** Operator ->
  Slicing -> Isosurface
- **Click** Draw
- **Click** Arrow to expand
- **Double-Click** Isosurface
- **Under select by choose** ->
  Percent(s) **enter** 50
- **Click** Apply & Dismiss
Create Pseudocolor and isosurfaces

- Click Add ->
  Pseudocolor ->
  hardyglobal
- Click Draw
- Click Operator ->
  Slicing -> Isosurface
- Click Draw
- Click Arrow to expand
- Double-Click Isosurface
- Under select by choose ->
  Percent(s) enter 50
- Click Apply & Dismiss
Create Pseudocolor and isosurfaces

- Click Add -> Pseudocolor -> hardyglobal
- Click Draw
- Click Operator -> Slicing -> Isosurface
- Click Draw
- Click Arrow to expand
- Double-Click Isosurface
- Under select by choose -> Percent(s) enter 50
- Click Apply & Dismiss
VisIt

Create Pseudocolor and isosurfaces

- **Double-Click** -> *Pseudocolor*
- **Change** Opacity
- **Click** Apply
- **Unselect** Apply operators/Selection to all plots
- **Click** Add -> *Pseudocolor* -> hardyglobal
- **Click** Operator -> Slicing -> *Isosurface*
- **Click** Arrow to expand
- **Double-Click** Isosurface
- **Under select by choose** -> *Percent(s)* enter 80
- **Click** Apply -> Dismiss -> Draw
Create Pseudocolor and isosurfaces

- **Double-Click** -> Pseudocolor
- **Change** Opacity
- **Click** Apply
- Unselect Apply operators/Selection to all plots
- **Click** Add -> Pseudocolor -> hardyglobal
- **Click** Operator -> Slicing -> Isosurface
- **Click** Arrow to expand
- **Double-Click** Isosurface
- Under select by choose -> Percent(s) enter 80
- **Click** Apply -> Dismiss -> Draw
Create Pseudocolor and isosurfaces

- Double-Click -> Pseudocolor
- Change Opacity
- Click Apply
- Unselect Apply operators/Selection to all plots
- Click Add -> Pseudocolor -> hardyglobal
- Click Operator -> Slicing -> Isosurface
- Click Arrow to expand
- Double-Click Isosurface
- Under select by choose -> Percent(s) enter 80
- Click Apply -> Dismiss -> Draw
Create Pseudocolor and isosurfaces

- Double-Click -> Pseudocolor
- Change Opacity
- Click Apply
- Unselect Apply operators/Selection to all plots
- Click Add -> Pseudocolor -> hardyglobal
- Click Operator -> Slicing -> Isosurface
- Click Arrow to expand
- Double-Click Isosurface
- Under select by choose -> Percent(s) enter 80
- Click Apply -> Dismiss -> Draw
Create Pseudocolor and isosurfaces

- Double-Click -> Pseudocolor
- Change Opacity
- Click Apply
- Unselect Apply operators/Selection to all plots
- Click Add -> Pseudocolor -> hardyglobal
- Click Operator -> Slicing -> Isosurface
- Click Arrow to expand
- Double-Click Isosurface
- Under select by choose ->Percent(s) enter 80
- Click Apply -> Dismiss -> Draw
Create Pseudocolor and isosurfaces

- **Double-Click** -> Pseudocolor
- **Change** Opacity
- **Click** Apply
- **Unselect** Apply operators/Selection to all plots
- **Click** Add -> Pseudocolor -> hardyglobal
- **Click** Operator -> Slicing -> Isosurface
- **Click** Arrow to expand
- **Double-Click** Isosurface
- **Under select by choose** ->Percent(s) enter 80
- **Click** Apply -> Dismiss -> Draw
VisIt

Clip Isosurfaces

- **Select** -> apply operators and selection to all plots
- **Click** Operators -> Selection -> Clip
- **Click** Draw
- **Double-Click** -> Clip
- **Click** Apply & Dismiss
- **Click** x (to delete)
- **Click** Draw
Clip Isosurfaces

• Select -> apply operators and selection to all plots

• Click Operators -> Selection -> Clip

• Click Draw

• Double-Click -> Clip

• Click Plane 2

• Click Apply & Dismiss

• Click x (to delete)

• Click Draw
Clip Isosurfaces

- Select -> apply operators and selection to all plots
- Click Operators -> Selection -> Clip
- Click Draw
- Double-Click -> Clip
- Click Plane 2
- Click Apply & Dismiss
- Click x (to delete)
- Click Draw
VisIt

Clip Isosurfaces

- **Select** -> apply operators and selection to all plots
- **Click** Operators -> Selection -> Clip
- **Click** Draw
- **Double-Click** -> Clip
- **Click** Plane 2
- **Click** Apply & Dismiss
- **Click** x (to delete)
- **Click** Draw
Clip Isosurfaces

- Select -> apply operators and selection to all plots
- Click Operators -> Selection -> Clip
- Click Draw
- Double-Click -> Clip
- Click Plane 2
- Click Apply & Dismiss
- Click x (to delete)
- Click Draw
VisIt

Clip Isosurfaces

- Select -> apply operators and selection to all plots
- Click Operators -> Selection -> Clip
- Click Draw
- Double-Click -> Clip
- Click Plane 2
- Click Apply & Dismiss
- Click x (to delete)
- Click Draw
Clip Isosurfaces

- **Select** -> apply operators and selection to all plots
- **Click** Operators -> Selection -> Clip
- **Click** Draw
- **Double-Click** -> Clip
- **Click** Plane 2
- **Click** Apply & Dismiss
- **Click** x (to delete)
- **Click** Draw
Slice Isosurfaces

- **Click** Operators -> Slicing -> Slice
- Double-Click -> Slice
- Select Z-Axis & Unselect Project to 2D
- Click Apply
- Click Dismiss
- Click Draw
VisIt

Slice Isosurfaces

- **Click** Operators -> Slicing -> Slice
- **Double-Click** -> Slice
- **Select** Z-Axis & Unselect Project to 2D
- **Click** Apply
- **Click** Dismiss
- **Click** Draw
VisIt

Slice Isosurfaces

- Click Operators -> Slicing -> Slice
- Double-Click -> Slice
- Select Z-Axis & Unselect Project to 2D
- Click Apply
- Click Dismiss
- Click Draw
VisIt

Slice Isosurfaces

- **Click Operators -> Slicing -> Slice**
- **Double-Click -> Slice**
- **Select Z-Axis & Unselect Project to 2D**
- **Click Apply**
- **Click Dismiss**
- **Click Draw**
Slice Isosurfaces

- **Click** Operators -> Slicing -> Slice
- **Double-Click** -> Slice
- **Select** Z-Axis & **Unselect** Project to 2D
- **Click** Apply
- **Click** Dismiss
- **Click** Draw
VisIt

Create Glyph of Vector

- **Unselect** Apply operators/ selection to all plots
- **Click** Add -> Vector -> airVfGradient
- **Click** Draw
- **Double click on** Vector
- **Under Vector amount enter** 1000
- **Click** Apply
- **Click** Dismiss
- **Click** Hide/Show
VisIt

Create Glyph of Vector

- **Unselect** Apply operators/ selection to all plots
- **Click** Add -> Vector -> airVfGradient
- **Click** Draw
- **Double click on** Vector
- Under Vector amount enter **1000**
- **Click** Apply
- **Click** Dismiss
- **Click** Hide/Show
Create Glyph of Vector

- **Unselect** Apply operators/selection to all plots
- **Click** Add -> Vector -> airVfGradient
- **Click** Draw
- **Double click on** Vector
- **Under Vector amount** enter **1000**
- **Click** Apply
- **Click** Dismiss
- **Click** Hide/Show
Create Glyph of Vector

- **Unselect** Apply operators/ selection to all plots
- **Click** Add -> Vector -> airVfGradient
- **Click** Draw
- **Double click on** Vector
- **Under Vector amount** enter 1000
- **Click** Apply
- **Click** Dismiss
- **Click** Hide/Show
VisIt

Create Glyph of Vector

- **Unselect** Apply operators/selection to all plots
- **Click** Add -> Vector -> airVfGradient
- **Click** Draw
- **Double click on** Vector
- **Under Vector amount enter** 1000
- **Click** Apply
- **Click** Dismiss
- **Click** Hide/Show
Create Streamlines

- **Click** Add -> Streamline -> grad
- **Double click on** Streamline
- **Under Source Type Select** Plane
  Enter:
  - Samples in X and Y: 15
  - Distance in X and Y: 20
  - Streamline Direction Both
  - Select limit Maximum Time Step
- **Click** Apply
- **Click** Dismiss
- **Click** Draw and Dismiss warning
- **Double click on** Streamline
Create Streamlines

- **Click** Add -> Streamline -> grad
- **Double click on** Streamline
- Under Source Type Select Plane
  - Enter:
    - Samples in X and Y: 15
    - Distance in X and Y: 20
    - Streamline Direction Both
    - Select limit Maximum Time Step
- **Click** Apply
- **Click** Dismiss
- **Click** Draw and Dismiss warning
- **Double click on** Streamline
Create Streamlines

- **Click** Add -> Streamline -> grad
- **Double click on** Streamline
- **Under Source Type Select** Plane
- **Enter:**
  - Samples in X and Y: 15
  - Distance in X and Y: 20
  - Streamline Direction Both
  - Select limit Maximum Time Step
- **Click** Apply
- **Click** Dismiss
- **Click** Draw and Dismiss warning
- **Double click on** Streamline
Create Streamlines

- Click **Add** -> **Streamline** -> **grad**
- Double click on **Streamline**
- Under Source Type Select **Plane**
- Enter:
  - Samples in X and Y: **15**
  - Distance in X and Y: **20**
  - Streamline Direction **Both**
  - Select **limit Maximum Time Step**
- Click **Apply**
- Click **Dismiss**
- Click **Draw and Dismiss warning**
- Double click on **Streamline**
Create Streamlines

- **Click** Add -> Streamline -> grad
- **Double click on** Streamline
- **Under Source Type Select** Plane
- **Enter:**
  - Samples in X and Y: 15
  - Distance in X and Y: 20
  - Streamline Direction Both
  - Select limit Maximum Time Step
- **Click** Apply
- **Click** Dismiss
- **Click** Draw and Dismiss warning
- **Double click on** Streamline
Create Streamlines

- **Click on** Appearance
- **Under Draw as** select Tubes -> Radius 0.005
- **Unselect** Show seeds
- **Unselect** Legend
- **Click** Apply
- **Under Data Value** select Variable -> Scalars -> hardyglobal
- **Click** Apply (dismiss warning)
- **Under Color** -> Color table, click Default Choose bluehot
- **Click** Apply & Dismiss
Create Streamlines

• Click on Appearance
• Under Draw as select Tubes -> Radius 0.005
• Unselect Show seeds
• Unselect Legend
• Click Apply
• Under Data Value select Variable -> Scalars -> hardyglobal
• Click Apply (dismiss warning)
• Under Color -> Color table, click Default Choose bluehot
• Click Apply & Dismiss
Create Streamlines

- Click on Appearance
- Under Draw as select Tubes -> Radius 0.005
- Unselect Show seeds
- Unselect Legend
- Click Apply
- Under Data Value select Variable -> Scalars -> hardyglobal
- Click Apply (dismiss warning)
- Under Color -> Color table, click Default Choose bluehot
- Click Apply & Dismiss
Create Streamlines

- Click on Appearance
- Under Draw as select Tubes –> Radius 0.005
- Unselect Show seeds
- Unselect Legend
- Click Apply
- Under Data Value select Variable –> Scalars –> hardyglobal
- Click Apply (dismiss warning)
- Under Color –> Color table, click Default Choose bluehot
- Click Apply & Dismiss
VisIt

Create Streamlines

- Click on Appearance
- Under Draw as select Tubes -> Radius 0.005
- Unselect Show seeds
- Unselect Legend
- Click Apply
- Under Data Value select Variable -> Scalars -> hardyglobal
- Click Apply (dismiss warning)
- Under Color -> Color table, click Default Choose bluehot
- Click Apply & Dismiss
VisIt

Background Color and Legend

- **Click on Controls -> Annotation**
- **Click on Colors**
- **Select Black for Background and White for Foreground**
- **Click on General**
- **Click no annotations**
- **Select legend**
- **Click Apply & Dismiss**
- **Hide Pseudocolor Plots**
VisIt

Background Color and Legend

• **Click on Controls** -> Annotation
• **Click on Colors**
• Select Black for Background and White for Foreground
• Click on General
• Click no annotations
• Select legend
• Click Apply & Dismiss
• Hide Pseudocolor Plots
VisIt

Background Color and Legend

- Click on Controls -> Annotation
- Click on Colors
- Select Black for Background and White for Foreground
- Click on General
- Click no annotations
- Select legend
- Click Apply & Dismiss
- Hide Pseudocolor Plots
VisIt

Background Color and Legend

- Click on Controls \rightarrow Annotation
- Click on Colors
- Select Black for Background and White for Foreground
- Click on General
- Click no annotations
- Select legend
- Click Apply & Dismiss
- Hide Pseudocolor Plots
VisIt

Background Color and Legend

- **Click on Controls** -> Annotation
- **Click on Colors**
- **Select Black for Background and White for Foreground**
- **Click on General**
- **Click no annotations**
- **Select legend**
- **Click Apply & Dismiss**
- **Hide Pseudocolor Plots**
VisIt

Background Color and Legend

- **Click on Controls -> Annotation**
- **Click on Colors**
- **Select Black for Background and White for Foreground**
- **Click on General**
- **Click no annotations**
- **Select legend**
- **Click Apply & Dismiss**
- **Hide Pseudocolor Plots**
VisIt

Background Color and Legend

- **Click on** Controls -> Annotation
- **Click on** Colors
- **Select Black for Background and White for Foreground**
- **Click Apply**
- **Click on** General
- **Click no annotations**
- **Select** legend
- **Click Apply & Dismiss**
- **Hide Pseudocolor Plots**
VisIt

Background Color and Legend

- Click on Controls -> Annotation
- Click on Colors
- Select Black for Background and White for Foreground
- Click Apply
- Click on General
- Click no annotations
- Select legend
- Click Apply & Dismiss
- Hide Pseudocolor Plots
VisIt

Create Slice

- **Click** Add -> Pseudocolor -> grad_magnitude
- **Click** Draw
- **Click** Operator -> Slicing -> Slice
- **Double click** on Slice
- **Select** Z Axis
- **Unselect** project to 2D
- **Click** Apply & Dismiss
- **Click** Draw
- **Click** Hide/Show
VisIt

Create Slice

- **Click** Add -> Pseudocolor -> \texttt{grad\_magnitude}
- **Click** Draw
- **Click** Operator -> Slicing -> Slice
- **Double click on** Slice
- **Select** Z Axis
- **Unselect** project to 2D
- **Click** Apply & Dismiss
- **Click** Draw
- **Click** Hide/Show
Create Slice

- **Click** Add -> Pseudocolor -> grad_magnitude
- **Click** Draw
- **Click** Operator -> Slicing -> Slice
- Double click on Slice
- **Select** Z Axis
- **Unselect** project to 2D
- **Click** Apply & Dismiss
- **Click** Draw
- **Click** Hide/Show
Create Slice

- Click Add
- Pseudocolor
- grad_magnitude
- Click Draw
- Click Operator
- Slicing
- Slice
- Double click on Slice
- Select Z Axis
- Unselect project to 2D
- Click Apply & Dismiss
- Click Draw
- Click Hide/Show
VisIt

Create Slice

- Click Add -> Pseudocolor -> grad_magnitude
- Click Draw
- Click Operator -> Slicing -> Slice
- Double click on Slice
- Select Z Axis
- Unselect project to 2D
- Click Apply & Dismiss
- Click Draw
- Click Hide/Show
VisIt

Create Slice

- **Click** Add --> Pseudocolor --> grad_magnitude
- **Click** Draw
- **Click** Operator --> Slicing --> Slice
- **Double click on** Slice
- **Select** Z Axis
- **Unselect** project to 2D
- **Click** Apply & Dismiss
- **Click** Draw
- **Click** Hide/Show
Create Slice

- Click **Add** -> Pseudocolor -> **grad_magnitude**
- Click **Draw**
- Click **Operator** -> Slicing -> **Slice**
- Double click on **Slice**
- Select **Z Axis**
- Unselect **project to 2D**
- Click **Apply & Dismiss**
- Click **Draw**
- Click **Hide/Show**
Create Volume Rendering

- **Click** Add -> Volume -> `grad_magnitude`
- **Click** Draw
- **Double click on** Volume
- **Click on 1D transfer function**
- **Change Transfer Function** (Under Opacity)
- **Click** Apply
- **Click** Dismiss
VisIt

Create Volume Rendering

- Click **Add** -> **Volume** -> **grad_magnitude**
- Click **Draw**
- **Double click on Volume**
- Click on **1D transfer function**
- Change Transfer Function (Under Opacity)
- Click **Apply**
- Click **Dismiss**
Create Volume Rendering

- **Click** Add -> Volume -> grad_magnitude
- **Click** Draw
- **Double click on** Volume
- **Click on** 1D transfer function
- **Change Transfer Function** (Under Opacity)
- **Click** Apply
- **Click** Dismiss
Create Volume Rendering

- Click **Add** -> **Volume** -> **grad_magnitude**
- Click **Draw**
- Double click on **Volume**
- Click on **1D transfer function**
- Change **Transfer Function** (Under **Opacity**)
- Click **Apply**
- Click **Dismiss**
VisIt

Create Volume Rendering

- **Click** Add -> Volume -> grad_magnitude
- **Click** Draw
- Double click on Volume
- **Click on 1D transfer function**
- Change Transfer Function (Under Opacity)
- **Click** Apply
- **Click** Dismiss
Questions?

• More tutorials available:
  – [https://wci.llnl.gov/codes/visit/manuals.html](https://wci.llnl.gov/codes/visit/manuals.html)

• More information:
  – [http://visitusers.org](http://visitusers.org)

• More help:
  – Visit User mailing list: visit-users@email.ornl.gov