Visualization with ParaView

Texas Advanced Computing Center
Before we begin...

- Make sure you have ParaView 3.14.1 installed so you can follow along in the lab section
Background

- Open-source, multi-platform parallel data analysis and visualization application
- Mature, feature-rich interface
- Good for general-purpose, rapid visualization
- Built upon the Visualization ToolKit (VTK) library
- Primary contributors:
  - Kitware, Inc.
  - Sandia National Laboratory
  - Los Alamos National Laboratory
  - Army Research Laboratory
Data Types

- Supports a wide variety of data types
  - Structured grids
    - uniform rectilinear, non-uniform rectilinear, and curvilinear
  - Unstructured grids
  - Polygonal data
  - Images
  - Multi-block
  - AMR
- Time series support
Visualization Algorithms

• Supports a wide variety of visualization algorithms -> Filters
  – Isosurfaces
  – Cutting planes
  – Streamlines
  – Glyphs
  – Volume rendering
  – Clipping
  – Height maps
  – …
Special Features

• Supports derived variables
  – New scalar / vector variables that are functions of existing variables in your data set

• Scriptable via Python

• Saves animations

• Can run in parallel / distributed mode for large data visualization
Data Formats

• Supports a wide variety of data formats
  – VTK (http://www.vtk.org/VTK/img/file-formats.pdf)
  – EnSight
  – Plot3D
  – Various polygonal formats

• Users can write data readers to extend support to other formats

• Conversion to the VTK format is straightforward
Data Formats

• VTK Simple Legacy Format
  • ASCII or binary
  • Supports all VTK grid types
  • Easiest for data conversion

• Note: use VTK XML format for parallel I/O

VTK simple legacy format (http://www.vtk.org/VTK/img/file-formats.pdf)
Data Formatting Example

- Data set: 4x4x4 rectilinear grid with one scalar variable

```vtk
# vtk DataFile Version 2.0
one scalar variable on a rectilinear grid
ASCII
DATASET RECTILINEAR_GRID
DIMENSIONS 4 4 4
X_COORDINATES 4 float
 0 1 2.5 4.5
Y_COORDINATES 4 float
 0 2 4 6
Z_COORDINATES 4 float
 0 3 6 9
POINT_DATA 64
SCALARS scalar_variable float 1
LOOKUP_TABLE default
 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
17 18 19 20 21 22 23 24 25 26 27 28 29 30
31 32 33 34 35 36 37 38 39 40 41 42 43 44
45 46 47 48 49 50 51 52 53 54 55 56 57 58
59 60 61 62 63
```
ParaView Visualization Pipeline

• All processing operations (filters) produce data sets

• Can further process the result of every operation to build complex visualizations
  – e.g. can extract a cutting plane, and apply glyphs (i.e. vector arrows) to the result
    • Gives a plane of glyphs through your 3D volume
Demonstration

- WRF weather forecast data set
  - Rectilinear grid
  - Multiple scalar and vector variables
  - Time series

- Can show:
  - Clouds
  - Wind
  - Temperature
  - ...
ParaView Test-Drive
Getting Started

• Download example data file
  • ‘disk_out_ref.ex2’
    – http://portal.longhorn.tacc.utexas.edu/training/
    – Right-click, Save link as…

• Open ParaView
ParaView

- Menu Bar
- Toolbars
- Pipeline Browser
- Object Inspector
- 3D View
ParaView

- **Undo/Redo**
- **Camera Controls**
- **View Controls (undo/redos)**
- **VCR Controls**
- **Common Controls**
- **Active Variable Controls**
ParaView

Today we will:

• Create isosurfaces for a scalar variable
• Clip and slice the surfaces
• Use glyphs to display a vector field
• Use streamlines to show flow through a vector field
• Edit color maps
• Add slices to show variable values over a plane
• Add color legends
• Create volume rendering
• Create a plot over a line
ParaView

Open the file

\texttt{disk\_out\_ref.ex2}

- Click File -> Open
- Select \texttt{disk\_out\_ref.ex2}
- Click OK
- Select ALL variables
- Click blue Apply
- Cylinder outline of dataset extent displayed
ParaView

Open the file

disk_out_ref.ex2

• Click File -> Open

• Select
disk_out_ref.ex2

• Click OK

• Select ALL variables

• Click blue Apply

• Cylinder outline of dataset extent displayed
ParaView

Open the file `disk_out_ref.ex2`
- Click **File** -> **Open**
- Select `disk_out_ref.ex2`
- Click **OK**
- Select **ALL** variables
- Click **blue Apply**
- Cylinder outline of dataset extent displayed
ParaView

Open the file

disk_out_ref.ex2

• Click File -> Open
• Select
disk_out_ref.ex2
• Click OK
• Select ALL variables
• Click blue Apply
• Cylinder outline of dataset extent displayed
ParaView

Manipulate Representation and color

- Use the Active Variable Controls to change color from Solid Color -> Pres
- Use Representation toolbar to change representation Surface -> Surface With Edges
- Click on Display tab
ParaView

Manipulate Representation and color

- Use the Active Variable Controls to change color from **Solid Color** -> **Pres**
- Use Representation toolbar to change representation **Surface** -> **Surface With Edges**
- Click on **Display tab**
ParaView

Manipulate Representation and color

- Use the Active Variable Controls to change color from Solid Color -> Pres

- Use Representation toolbar to change representation Surface -> Surface With Edges

- Click on Display tab
ParaView

Manipulate Representation and color

- **Review** Color by
- Review Representation
- Enable Color Legend by clicking on icon in toolbar
- Click $+\ \underline{Z}$ view button
- Explore dataset with mouse
- Select Orientation Axes and change location
ParaView

Manipulate Representation and color
- **Review** Color by
- **Review** Representation
- Enable Color Legend by clicking on icon in toolbar
- Click +Z view button
- Explore dataset with mouse
- Select Orientation Axes and change location
Manipulate Representation and color

- **Review** Color by
- Review Representation
- **Enable Color Legend by clicking on icon in toolbar**
- Click $\pm$ view button
- Explore dataset with mouse
- Select Orientation Axes and change location
Manipulate Representation and color

- Review Color by
- Review Representation
- Enable Color Legend by clicking on icon in toolbar
- Click +Z view button
- Explore dataset with mouse
- Select Orientation Axes and change location
 ParaView

Manipulate Representation and color

- Review Color by
- Review Representation
- Enable Color Legend by clicking on icon in toolbar
- Click +Z view button
- Explore dataset with mouse
- Select Orientation Axes and change location
Manipulate Representation and color

- **Review** Color by
- **Review** Representation
- Enable Color Legend by clicking on icon in toolbar
- Click +Z view button
- Explore dataset with mouse
- Select Orientation Axes and change location
ParaView

Manipulate Representation and color

- **Review** Color by
- **Review** Representation
- Enable Color Legend by clicking on icon in toolbar
- Click $+\mathbb{Z}$ view button
- Explore dataset with mouse
- Select Orientation Axes and change location
Filters

- **Click** Filters
- **Click** Filters -> Common -> Contour
- **Press** alt+space (mac)/ ctrl+space (win/linux)
- **Enter** contour
- **Press** esc twice
Filters

- Click Filters
- Click Filters → Common → Contour
- Press alt+space (mac)/ ctrl+space (win/linux)
- Enter contour
- Press esc twice
ParaView

Filters

- Click Filters
- Click Filters -> Common -> Contour
- Press `alt+space` (mac)/`ctrl+space` (win/linux)
- Enter contour
- Press `esc` twice
Filters

- Click Filters
- Click Filters -> Common -> Contour
- Press alt+space (mac)/ ctrl+space (win/linux)
- Enter contour
- Press esc twice
Create isosurfaces

- **Click** Filters -> Common -> Contour
- In Contour By, **select** Temp
- **Click** Delete All
- **Click** New Value
- Enter 400
- **Click** blue **Apply**
- **Click** the eye icon next to disk_out_ref.ex2
- Change representation to **Wireframe**
ParaView

Create isosurfaces

- Click Filters -> Common -> Contour
- In Contour By, select Temp
- Click Delete All
- Click New Value
- Enter 400
- Click blue Apply
- Click the eye icon next to disk_out_ref.ex2
- Change representation to Wireframe
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- **In** Contour By, **select** Temp
- **Click** Delete All
- **Click** New Value
- **Enter** 400
- **Click** blue **Apply**
- **Click** the eye icon next to disk_out_ref.ex2
- **Change** representation to Wireframe
ParaView

Create isosurfaces

- Click Filters -> Common -> Contour
- In Contour By, select Temp
- Click Delete All
- Click New Value
- Enter 400
- Click blue Apply
- Click the eye icon next to disk_out_ref.ex2
- Change representation to Wireframe
ParaView

Create isosurfaces

- Click Filters -> Common -> Contour
- In Contour By, select Temp
- Click Delete All
- Click New Value
- Enter 400
- Click blue Apply
- Click the eye icon next to disk_out_ref.ex2
- Change representation to Wireframe
Create isosurfaces

- Click Filters -> Common -> Contour
- In Contour By, select Temp
- Click Delete All
- Click New Value
- Enter 400
- Click blue Apply
- Click the eye icon next to disk_out_ref.ex2
- Change representation to Wireframe
ParaView

Create isosurfaces

- Click Filters -> Common -> Contour
- In Contour By, select Temp
- Click Delete All
- Click New Value
- Enter 400
- Click blue Apply
- Click the eye icon next to disk_out_ref.ex2
- Change representation to Wireframe
ParaView

Create isosurfaces

- **Click** Filters -> Common -> Contour
- **In** Contour By, **select** Temp
- **Click** Delete All
- **Click** New Value
- **Enter** 400
- **Click** blue Apply
- **Click** the eye icon next to disk_out_ref.ex2
- **Change** representation to Wireframe
ParaView

Extract Surface

• **Click** Filters -> Alphabetical -> Extract Surface
• **Click blue Apply**
ParaView

Extract Surface

- Click Filters -> Alphabetical -> Extract Surface
- Click blue Apply
ParaView

Clip Surface

- **Click** Filters -> Common -> Clip
- Show Plane should be checked
- Click Y Normal and enter -1 in second box under Normal
- Click blue Apply
- Unselect Show Plane
ParaView

Clip Surface

- **Click** Filters -> Common -> Clip
- **Show Plane** should be checked
- **Click Y Normal** and enter 
  -1 in second box under Normal
- **Click blue Apply**
- **Unselect** Show Plane
Clip Surface

- Click Filters -> Common -> Clip
- Show Plane should be checked
- Click Y Normal and enter -1 in second box under Normal
- Click blue Apply
- Unselect Show Plane
ParaView

Clip Surface

- Click Filters -> Common -> Clip
- Show Plane should be checked
- Click Y Normal and enter -1 in second box under Normal
- Click blue Apply
- Unselect Show Plane
ParaView

Clip Surface

- Click Filters -> Common -> Clip
- Show Plane should be checked
- Click Y Normal and enter $-1$ in second box under Normal
- Click blue Apply
- Unselect Show Plane
ParaView

Slice Surface

- Click *disk_out_ref.ex2* in Pipeline Browser
- Click Filters -> Common -> Slice
- Click blue Apply
- Click eye next to ExtractSurface1 and Clip1 to hide clip plot
- Click on Y Normal
- Click blue Apply
- Change Color By to Temp
Slice Surface

- Click `disk_out_ref.ex2` in Pipeline Browser
- Click **Filters -> Common -> Slice**
- **Click blue Apply**
- Click eye next to `ExtractSurface1` and `Clip1` to hide clip plot
- **Click on Y Normal**
- **Click blue Apply**
- **Change Color By to Temp**
ParaView

Slice Surface

- Click `disk_out_ref.ex2` in Pipeline Browser
- Click Filters -> Common -> Slice
- Click blue Apply
- Click eye next to `ExtractSurface1` and `Clip1` to hide clip plot
- Click on Y Normal
- Click blue Apply
- Change Color By to Temp
ParaView

Slice Surface

- Click `disk_out_ref.ex2` in Pipeline Browser
- Click Filters -> Common -> Slice
- Click blue Apply
- Click eye next to `ExtractSurface1` and `Clip1` to hide clip plot
- Click on Y Normal
- Click blue Apply
- Change Color By to Temp
ParaView

Slice Surface

- Click `disk_out_ref.ex2` in Pipeline Browser
- Click Filters -> Common -> Slice
- Click blue Apply
- Click eye next to `ExtractSurface1` and `Clip1` to hide clip plot
- Click on Y Normal
- Click blue Apply
- Change Color By to Temp
ParaView

Create Streamlines

• **Click** `disk_out_ref.ex2` in Pipeline Browser

• **Click Filters -> Common -> Stream Tracer**

• **Click blue Apply**
ParaView

Create Streamlines

- Click `disk_out_ref.ex2` in Pipeline Browser
- Click Filters -> Common -> Stream Tracer
- Click blue Apply
ParaView

Create Tubes

- **Click** *StreamTracer1* in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tube
- **Click** blue *Apply*
ParaView

Create Tubes

- **Click** StreamTracer1 in Pipeline Browser
- **Click** Filters -> Alphabetical -> Tube
- **Click blue Apply**
ParaView

Create Tubes

• Click StreamTracer1 in Pipeline Browser

• Click Filters -> Alphabetical -> Tube

• Click blue Apply
ParaView

Create Glyph of Vector Field

- **Click** StreamTracer1 in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Select** \( V \) under Vectors box
- **Select** Cone under Glyph Type
- **Click** blue Apply
- **Click** on Tube1 and change to Solid Color
Create Glyph of Vector Field

- Click StreamTracer1 in Pipeline Browser
- Click Filters -> Common -> Glyph
- Select V under Vectors box
- Select Cone under Glyph Type
- Click blue Apply
- Click on Tube1 and change to Solid Color
ParaView

Create Glyph of Vector Field

- Click `StreamTracer1` in Pipeline Browser
- Click `Filters -> Common -> Glyph`
- Select `V` under `Vectors` box
- Select `Cone` under `Glyph Type`
- Click blue `Apply`
- Click on `Tube1` and change to `Solid Color`
Create Glyph of Vector Field

- **Click** `StreamTracer1` in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Select** V under Vectors box
- **Select** Cone under Glyph Type
- **Click** blue **Apply**
- **Click on** Tube1 and change to Solid Color
ParaView

Create Glyph of Vector Field

- Click StreamTracer1 in Pipeline Browser
- Click Filters -> Common -> Glyph
- Select V under Vectors box
- Select Cone under Glyph Type
- Click blue Apply
- Click on Tube1 and change to Solid Color
ParaView

Create Glyph of Vector Field

- **Click** StreamTracer1 in Pipeline Browser
- **Click** Filters -> Common -> Glyph
- **Select** V under Vectors box
- **Select** Cone under Glyph Type
- **Click on** Tube1 and change to Solid Color
ParaView

Edit Color Map

- **Click on Glyph in Pipeline Browser**
- **Click on Display -> Edit Color Map**
- **Click Choose Preset**
- **Select BLUE...HSV**
- **Click blue OK**
- **Click blue Close**
Edit Color Map

- **Click on Glyph** in Pipeline Browser
- **Click on Display -> Edit Color Map**
- **Click Choose Preset**
- **Select BLUE...HSV**
- **Click blue OK**
- **Click blue Close**
ParaView

Edit Color Map

• Click on Glyph in Pipeline Browser
• Click on Display -> Edit Color Map
• Click Choose Preset
• Select Blue to Red
• Click blue OK
• Click blue Close
ParaView

Edit Color Map

- Click on Glyph in Pipeline Browser
- Click on Display -> Edit Color Map
- Click Choose Preset
- Select Blue to Red
- Click blue OK
- Click blue Close
ParaView

Edit Color Map

- Click on Glyph in Pipeline Browser
- Click on Display -> Edit Color Map
- Click Choose Preset
- Select Blue to Red Rai.. HSV
- Click blue OK
- Click blue Close
ParaView

Background Color

- Click the button above the 3D view or click Edit -> View Settings
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Background Color

• Click the button above the 3D view or click Edit -> View Settings
• **Click** Choose Color
• Drag box to black
• Click blue **Ok**
• Click blue **Ok**
ParaView

Background Color

- Click the button above the 3D view or click Edit -> View Settings
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Background Color

- Click the button above the 3D view or click Edit -> View Settings
- Click Choose Color
- Drag box to black
- Click blue Ok
- Click blue Ok
ParaView

Enable/Edit Color Legend

- **Click and Show Clip1**
- **Click Display**
- **Click Edit Color Map**
- **Click Color Legend**
- **Click Show Color Legend**
- **Click -> Blue Close**
- **Select Color Legend (notice white rectangle) and move to top of 3D viewer**
ParaView

Enable/Edit Color Legend

- Click and Show Clip1
- Click Display
- Click Edit Color Map
- Click Color Legend
- Click Show Color Legend
- Click → Blue Close
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable/Edit Color Legend

- Click and Show Clip1
- Click Edit Color Map
- **Click** Color Legend
- Click Show Color Legend
- Click → Blue Close
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
Enable/Edit Color Legend

- Click and Show Clip1
- Click Edit Color Map
- Click Color Legend
- **Click** Show Color Legend
- Click → Blue Close
- Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable/Edit Color Legend

- **Click and Show Clip1**
- **Click** Edit Color Map
- **Click** Color Legend
- **Click** Show Color Legend
- **Click** -> Blue Close
- **Select** Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Enable/Edit Color Legend

• Click and Show Clip1
• Click Edit Color Map
• Click Color Legend
• Click Show Color Legend
• Click -> Blue Close
• Select Color Legend (notice white rectangle) and move to top of 3D viewer
ParaView

Create Volume Rendering

- **Click** disk_out_ref.ex2 in Pipeline Browser
- **Under** Representation **select** Volume
- **Show** disk_out_ref.ex2 **if** hidden
- **Hide** Clip1
- **Click** Display
- **Click** -> Edit Color Map (To edit transfer function)
- **Click** Choose Preset
- **Choose** Black, Orange, .. RGB
- **Modify** Function
- **Click** Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- **Under** Representation **select** Volume
- **Show** `disk_out_ref.ex2` **if hidden**
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose **Black, Orange, ..** RGB
- Modify Function
- Click Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- Under Representation select Volume
- Show `disk_out_ref.ex2` if hidden
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose Black, Orange, .. RGB
- Modify Function
- Click Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- Under Representation select Volume
- Show `disk_out_ref.ex2` if hidden
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose Black, Orange, .. RGB
- Modify Function
- Click Close
ParaView

Create Volume Rendering

- **Click** *disk_out_ref.ex2* in Pipeline Browser
- **Under** Representation **select** Volume
- **Show** *disk_out_ref.ex2* if hidden
- **Hide** Clip1
- **Click** Display
- **Click** -> Edit Color Map (To edit transfer function)
  - **Click** Choose Preset
  - **Choose** Black, Orange, .. RGB
  - **Modify** Function
  - **Click** Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- Under Representation select Volume
- Show `disk_out_ref.ex2` if hidden
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose Black, Orange, .. RGB
- Modify Function
- Click Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- Under Representation select Volume
- Show `disk_out_ref.ex2` if hidden
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose Black, Orange, .. RGB
- Modify Function
- Click Close
ParaView

Create Volume Rendering

• Click `disk_out_ref.ex2` in Pipeline Browser
• Under Representation select Volume
• Show `disk_out_ref.ex2` if hidden
• Hide Clip1
• Click Display
• Click -> Edit Color Map (To edit transfer function)
• Click Choose Preset
• Choose Black, Orange, .. RGB
• Modify Function
• Click Close
ParaView

Create Volume Rendering

- Click `disk_out_ref.ex2` in Pipeline Browser
- Under Representation select Volume
- Show `disk_out_ref.ex2` if hidden
- Hide Clip1
- Click Display
- Click -> Edit Color Map (To edit transfer function)
- Click Choose Preset
- Choose Black, Orange, .. RGB
- Modify Function
- Click Close
ParaView

Plot Over Line

• **Click disk_out_ref.ex2** in Pipeline Browser
• Change object representation to **Wireframe**
• **Click Filters -> Data Analysis -> Plot Over Line**
• Move the line that appears on the 3D view to intersect the Object vertically
• **Click blue Apply**
• **Click Display**
ParaView

Plot Over Line

- Click `disk_out_ref.ex2` in Pipeline Browser
- Change object representation to Wireframe
- Click Filters -> Data Analysis -> Plot Over Line
- Move the line that appears on the 3D view to intersect the Object vertically
- Click blue Apply
- Click Display
ParaView

Plot Over Line

- **Click** `disk_out_ref.ex2` in Pipeline Browser
- **Change object representation to Wireframe**
- **Click** Filters -> Data Analysis -> Plot Over Line
- **Move the line that appears on the 3D view to intersect the Object vertically**
- **Click** blue **Apply**
- **Click** Display
ParaView

Plot Over Line

- Click `disk_out_ref.ex2` in Pipeline Browser
- Change object representation to Wireframe
- Click Filters -> Data Analysis -> Plot Over Line
- Move the line that appears on the 3D view to intersect the Object vertically
  - Click blue Apply
  - Click Display
ParaView

Plot Over Line

• Click `disk_out_ref.ex2` in Pipeline Browser

• Change object representation to Wireframe

• Click Filters -> Data Analysis -> Plot Over Line

• Move the line that appears on the 3D view to intersect the Object vertically

• Click blue Apply

• Click Display
ParaView

Start and Stop Trace

- **Click** Edit -> Delete All (or Save your state before deleting: File -> Save State)
- **Click** Tools -> Start Trace
- Create a contour of Temperature (Filters -> Common -> Contour)
- **Click** Tools -> Stop Trace
ParaView

Start and Stop Trace

- **Click** Edit -> Delete All (or Save your state before deleting: File -> Save State)
- **Click** Tools -> Start Trace
- **Create a contour of Temperature** (Filters -> Common -> Contour)
- **Click** Tools -> Stop Trace
ParaView

Start and Stop Trace

- **Click** Edit -> Delete All (or Save your state before deleting: File -> Save State)
- **Click** Tools -> Start Trace
- Create a contour of Temperature (**Filters** -> **Common** -> **Contour**)
- **Click** Tools -> Stop Trace
ParaView

Python Shell

- **Click** Tools -> Python
- Voila!
ParaView

Python Shell

- Click **Tools -> Python**
- **Voila!**
Questions?

• More tutorials available:
  – http://www.paraview.org/Wiki/The_ParaView_Tutorial